Mobula6hd ファームをアップデート!

2020-08-19Drone

Mobula6HDのファームをアップしてみた・・・というキロク

ウチのMobula6HDはベータフライトのファームのバージョンが3.5.7のままなんだけど、Betaflight Configuratorは10.7.0と最新。ネットで見ると、3.5.7には10.4を使え!みたいになってるけど、特に問題なく設定できるようなので、そのまま使っている。バージョン違いを同居させるにはノウハウがあるらしい。

でも、そのせいなのか、バッテリーを繋いでも、画像が来ないことがたまにある。(プロペラは動くけど、画像が映らない)
何度かSDカードを抜き差しすると直るが、先日は飛んでる最中に突然映らなくなった!めっちゃ困る。
本体が壊れた可能性もある(まだ数える程しか飛ばしてない)けど、Betaflightに繋ぐ時に映らないことは無いし・・・

困る男性のイラスト | かわいいフリー素材集 いらすとや

で、よく分からないまま、
Mobula6HDファームをアップデートしてみることにした。
新しい方がいいんじゃないかと(^^;)

バックアップは取ってあるので、いきなりアップデートに進もう!

機体をPCに繋ぐ時間が長くなるので、扇風機で機体を冷やします!必須と思います

現在のファームウェアのバージョンは以下の通り。

# version
# Betaflight / CRAZYBEEF4FR (C4FR) 3.5.7 Mar 15 2019 / 21:42:20 (e9130527c) MSP API: 1.40


DFUモードにする方法がわからない(^^;) ので、見習い魔法使いキヨっちcalmzeroさんの情報を参考にして、ImpulseRC Driver Fixer というのをダウンロードします。HPはここ

ダウンロードしたファイルを起動すると、

いきなりこんなのが出たので、慌ててMobula6HDをPCと繋ぎました。するとDFUのドライバーがインストールされ、しばらくすると完了と共に変なメッセージが!

クロームはドライバーを修正しながら実行した。
ConfiguratorがFCを検知する前にクロームを閉じろ。
PCの再起動を推奨する。

みたいな内容。


素直に、ソフトを全部閉じて、PCを再起動し、最初からやり直します。
PCが立ち上がったら、まず、Mobula6HDをPCにつないでから、ImpulseRCを起動します。今度はエラーが出ずに完了!その後、機体をPCに繋いだままBetaflight Configuratorを起動して、立ち上がった後、10秒位待っていると、

と、DFUに変わりました!!

ファームフラッシャーをクリックすると、

こんな感じです。再起動シーケンスなし、チップメモリ完全消去を入れました(完全に受け売り)。


ファームウェアを選択(Online)を押すと、

こうなりました。 あとは、 ファームウェアの更新 を押すだけ・・・緊張しつつポチッと!
メモリ消去して、書き込み・・・

上手く行ったようです!!


自動的にDFUモードは解除され、

通常に戻っています。良く出来てる。UpdateFirmwareを切り、となりの接続を押すと、

こんなのが出ました! 適用するしかないので、適用を押して、接続を押します。すると更に・・・

加速度センサーのキャリブレーションが必要との警告。そりゃそうだろう。

水平キャリブレーションを実施しました。今更ながらファームは4.2.2になってる!!


さて、調整は全部やり直しのはず・・・まずは、ポートから。


早速、VTXが設定されていない・・・以前のようにUART2に設定したら、警告出ました!
”VTXタブでVTXテーブルを設定してください”・・・
なるほど、いつの間にかメニューにVTX設定というのがある!

VTX設定に移り、

こうしてみました。モードって何かわからず、drone4ブログさんを参考にさせて頂きましたm(_ _)m
でもエキスパートモードなので、全部はマネできず・・・

送信出力レベルの下の 2 や MAX は、
RTC6705(USA)を参考にしました。

紛らわしいですが、略号A-5705は1個目-出力MAX になっているようです!
Mobula6HDのVTXは25mAですが(^^;)


続いて 基本設定。これまた全然変わってる!

モータの逆回転から直します。気圧センサーとコンパスを消し、Motor_stopをONにして、双方向はOFFのままです。(ONにすると、それに関する定義もしないと動きません。とりあえずOFFで)
アーミングは180度にします。(良かれと思って、CW90°を”デフォルト”にしたら、機体がひっくり返るようになりました)

機体名入れて、カメラ角度入れて、

AIRMODE常時を切り、あとはこんな感じで以前に合わせます。保存して再起動を押します。


次は 電源。

電圧設定をちょっと変えました。電流メータのスケールは、以前は1175で今は179・・・分かりません。
キャリブレーションはとりあえずしません。これで保存します。


PIDチューニングです。

上が初期画面。どうすりゃいいの?・・・しばらく見てたら少しわかってきて、

自動で設定してくれるようなので、とりあえず、少し落としてビギナー向けみたいな設定にスライドバーを動かしました。フィードフォワードも変更したかな。

Pateprofileは RCexpoだけ 0→0.2 にしてみました。

フィルターはデフォルトのまま。


続いて 受信機

こうなってました。

プロポをPCにつないでも 画面上で全く反応しない・・・そうか、ファームを変えたから、プロポと機体のバインドをやり直さんといかんのか!プロポのMobula6HDのファイルの中からBindを押したらできました。
そのままPCと繋ぐと、反応しました。反転とかも問題ないようなので、そのまま保存。


次は、モード。何も入ってません。

これは、これまで通り、

こうして、保存。


モータは何もせず、OSDへ。これまた何も入ってないので、

タイマー2のアラームを2分にして、表示は、

とりあえず、並べてみた。保存してひとまず終了!


最後にバックアップを取ります。CLIコマンドライン で diff all と入れてリターン。
ファイルへ保存を押して、保存します。


とりあえず、この設定でアングルモードで飛ぶことを確認しました!(1分程だけど)
以前の設定よりのんびりした感じかな・・・
夜になったので、ちゃんとは飛ばせてない。

結構時間かかったけど、良くなったかな(^^;)

画像が出ない不具合が無くなることを期待してます!

■■■ 翌日、外で少し飛ばした感じでは、以前の不具合は出てません! ■■■


Velocidroneフライトシミュレータ導入!

Happymodel Mobula6 HD キター

マイクロドローン入門:BetaFlight Configrator インストール

EACHINE EV800がキター!

Jumper T8SG V2(V3) PLUS キター! 早速ハマる!!

マイクロドローン開局申請! 詳細その2(JARD)→届いた!

Eachine TRASHCAN 75mm キター!

マイクロドローンの門を叩く?!

ついに包括申請完了!(DJI spark)

Drone

Posted by mmhトホホ